Error: MapView Exception during draw Age of Wonders 1

Home Forums Age of Wonders Classics Discussions Error: MapView Exception during draw Age of Wonders 1

This topic contains 6 replies, has 2 voices, and was last updated by  pest4422 8 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #244687

    pest4422
    Member

    So I recently reinstalled AoW 1 on my windows 10 rig from Steam and I am constantly getting this error message pop up. It causes the game to freeze and it must be ctrl-alt deleted to be closed.

    I’ve been struggling with this issue for about a week now and have found no solutions online that have worked so far.

    I am launching the game in compatibility mode since starting it normally just causes an immediate crash. It is also in windowed mode and then maximized.

    Any ideas or solutions out there?

    #244735

    Thariorn
    Member

    Did you tick the compatibilty options
    Deactivate visual Designs
    and
    Deactivated desktopdesigns ?

    Because most pre XP Games tend to struggle with those two.

    Another problem could be the explorer.exe, which you could terminate while in the task-manager and after closing the game down restart it via the task-manager too.

    • This reply was modified 8 months ago by  Thariorn.

    No Mod, but I try to help - Bane of Cockatrice, a Star and an Onion.
    Check out the (not so) official List of Map-Projects aswell as the List of Mod-Projects

    #244740

    pest4422
    Member

    Did you tick the compatibilty options
    Deactivate visual Designs
    and
    Deactivated desktopdesigns ?

    Because most pre XP Games tend to struggle with those two.

    Another problem could be the explorer.exe, which you could terminate while in the task-manager and after closing the game down restart it via the task-manager too.

    Hi and thanks for responding!

    So I’m not sure how to tick both “deactivate visual designs and desktop designs”. I’m looking in the aow 1 settings under configuration and not seeing them there.

    I will try terminating explorer to see if that helps.

    Thank you!

    #244747

    Thariorn
    Member

    Ehh, Up to at least Windows 7 all you have to do is right-click the game’s shortcut/executable, select settings, select the “Compatibility-tab” and in there in the settings part tick both those boxes.

    The following window showcases the compatibility-tab of an AoW-Shortcut on my german rig.
    The “Eigenschaften”-Part is the settings-part and the 3rd and 4th tick-boxes are the ones I’ve been trying to explain.

    No Mod, but I try to help - Bane of Cockatrice, a Star and an Onion.
    Check out the (not so) official List of Map-Projects aswell as the List of Mod-Projects

    #244774

    pest4422
    Member

    This is the compatibility window I see in Windows 10:

    Attachments:
    You must be logged in to view attached files.
    #244790

    Thariorn
    Member

    Ehh, that`s odd.

    I guess that means Aero is the default vor Windows 10 :S

    If that’s the case I’m all out of ideas :/

    No Mod, but I try to help - Bane of Cockatrice, a Star and an Onion.
    Check out the (not so) official List of Map-Projects aswell as the List of Mod-Projects

    #244808

    pest4422
    Member

    I appreciate your help in any case Thariorn!

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.