[bug, 16036] Reproductible forced quit (Stack Move Action failed!)

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Update v1.5 – Open Beta Linux Specific [bug, 16036] Reproductible forced quit (Stack Move Action failed!)

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  ephafn 6 years, 6 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #202067

    ephafn
    Member

    I have a savefile (that I can send you if needed) such that if I load it and start a new turn, I consistently have my game close after a small amount of time, even if I do nothing (beside ending the turn). I say forced quit instead of CTD since the screen turn black, I hear the first note of the main screen music, then the game close.

    I believe this is the relevant part of the debug log (I only tested with the debug mode on):

    
    [21:35:08][ERROR]Stack Move Action failed! Stack is not registered on the cell!
    [21:35:09][ERROR]Assertion failed: "Action->ValidateEx(FContext->PathFinder)" 
    [21:35:09]Message: Move scheduler is trying to queue an invalid action! 
    [21:35:09]/home/lascha/Triumph/SourceSteam/AoW/AoWC/Source/AgeOfWonders/StrategicMap/AI/Movement/AIMoveScheduler.cpp(140): (click to open)
    [21:35:09]
    [21:35:09][ERROR]Stack Move Action failed! Stack is not registered on the cell!
    [21:35:09][ERROR]Failed to queue an action! Action failed validation! (PlayerID: 2): TStackMoveAction
    [21:35:09][STATE -] SYSTEM: GAME_PLAY
    [21:35:09][STATE +] SYSTEM: GAME_CLOSE
    [21:35:09]Game Session - Stop
    [21:35:10]Game Session - Ready
    [21:35:10]Game Session - Shutdown
    [21:35:10]HUD for noname hidden!
    [21:35:10]Heap: World - Leaking memory! (Allocations left: 29570)
    [21:35:10]Report for heap World:
    [21:35:10]max system bytes =   92602368
    [21:35:10]system bytes     =   87031808
    [21:35:10]in use bytes     =   14272592
    [21:35:10]Game Session - Done
    [21:35:10]Closing Game Session
    [21:35:11][STATE -] SYSTEM: GAME_CLOSE
    [21:35:12]Release device called
    [21:35:12]Destroying Window..
    [21:35:13]Terminate duration: 1.353 seconds
    
    #202398

    ephafn
    Member

    I just tested with the new build (16112) with the same savefile, and the bug is still there.

    #202848

    ephafn
    Member

    I am having the exact same problem with a new game, started in the current build (16112). Exact same symptoms, and same messages in the debug log.

    Should I send both save files?

    #202849

    ephafn
    Member

    Just in case, I tested both save files with debug mode disabled. And so far, I haven’t had any problem. So the bug may only be in debug mode.

    #204815

    Lascha
    Moderator

    Ah sorry for the late reply. If you still have the save file I’m very interested in looking into this issue. It’s probably not Linux specific though.

    #204864

    ephafn
    Member

    Sent both save files to the savegames@* email address.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.