Common Trouble Shooting & Support

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Help & Support Common Trouble Shooting & Support

This topic contains 0 replies, has 1 voice, and was last updated by  Arnout 7 years, 4 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #215971

    Arnout
    Keymaster

    1. Basic Troubleshooting

    The following steps can resolve most game crashes, general problems, errors and problems with registration:

    • Log out of steam (really logout: Steam -> Change User), exit steam and then login again
    • Age of Wonders III should always launched from Steam or Steam should be online when you run the game
    • Verify the game cache in Steam
    • Check if your Steam Client it up to date.
    • Disable your Anti-Virus. It might be preventing the game from launching.
    • Check if any other programs interfere with Steam and/or the game.
    • Disable all mods (if any) in the Age of Wonders III Launcher.
    • Update your graphics drivers. Many problems are being caused by out of date videocard drivers. nVidia Geforce | AMD Catalyst | Intel HD Driver
    • Update DirectX using the following link.
    • Reboot your computer

    2. Registration & Age of Wonders III Launcher

    2.1 Where is my key?
    You don’t need a key if you bought the game via Steam. If you make a Triumph Account in the Age of Wonders III Launcher and then link your Steam account to it, you will be registered automatically. This can be done and verified at the ‘Register key / DLC / Account Settings’ screen of the Age of Wonders III Launcher.

    2.2 Cannot ‘Link to STEAM account’, steam user already assigned
    Previously you’ve linked your Steam Account to another Triumph Account. If you don’t know which triumph account or cannot login anymore, please email AoW3Support@triumphstudios.com mentioning the triumph account you’re trying to link to steam.

    2.3 Unable to link account to Steam, Greyed out
    Please try to log out of steam (really logout: Steam -> Change User), exit steam and then login again. Start Age of Wonders III from Steam Game Library and in the Game’s Launcher try to link again.

    If it still doesn’t work it might be that Steam and the game are run in a sandbox. Please check if any programs might be interfering with Steam and/or the game.

    2.4 “Could not save account. Disk full” error
    This means Age of Wonders III cannot write data to your hard-disk. However the most likely cause is that your profile somehow got corrupted. Please delete the following directory C:\Users\you\Documents\My Games\AoW3

    Backup any save games first. Saves can be found here C:\Users\you\Documents\My Games\AoW3\Profiles\accountname\SAVES

    Windows 10 upgrade users should check and update folder permissions for the \Documents folder if its read-only. Anti-Virus program might also be the cause of this problem.

    2.5 “Cannot Launch: Installation Invalid” error
    Cause: the AoW3.exe is launched from the AoW3Launcher.exe, but fails. Either the AoW3.exe isn’t there or is blocked.

    Solution is to verify the game cache or reinstall the game. If this doesn’t solve the problem an external program (like Anti-Virus or Anti-Malware program) might be blocking the game.

    To verify if a program is blocking the game from starting, open a Command Prompt (CMD.exe) and enter:

    CD C:\Program Files (x86)\Steam\steamapps\common\AoW3
    AoW3.exe -profile YourTriumphAccountName -no_registration

    2.6 Changing the email-address of your Triumph-Account
    You can change your email address in the Age of Wonders 3 Launcher. Please open the ‘Register key / DLC / Account Settings’ screen of the Age of Wonders III Launcher and click on the ‘Change Email’ button.

    3. Solutions for common problems

    3.1 DLC Gone missing
    Please try to log out of steam (really logout: Steam -> Change User), exit steam and then login again. Start Age of Wonders III from Steam Game Library and the problem should be gone. The problem might also happen if you launch the game from outside Steam.

    Anti-Virus program might run the game in a sandbox and would explain the DLCs aren’t loaded as well. Please white list Steam and all the Age of Wonders III executables.

    3.2 Poor Performance
    It might be that your integrated videocard is set to default for Age of Wonders III. To change this for nVidia:

    1. Go to the nVIDIA control panel.
    2. Go to “Manage 3D Settings”, “Program Settings”
    3. Add “AoW3.exe” and “AoW3_debug.exe” on the drop-list and set the ‘Power Management mode’ feature to ‘Prefer maximum performance’.

    For AMD:

    1. Open AMD Catalyst Center
    2. Go to the switchable Graphic Application settings & click on Add application
    3. Select the AoW3.exe” and “AoW3_debug.exe” and set it to high performance.

    3.3 Blank spaces in the start menus where normally icons should be
    This happens when the game doesn’t have the necessary hardware resources to run the game properly. Please check if your computer meets the minimum system requirements to run the game.

    3.4 Game crashes during loading (at the loading screen)
    There is an issue where steam’s auto updater left some old files in the AoW3 steam directory, which are now causing issues. To solve this:

    1. Uninstall Age of Wonders 3
    2. Exit Steam
    3. Goto steam install directory (C:\program files (x86)\Steam\SteamApps\Common)
    4. Delete \AoW3 folder here
    5. Install Age of Wonders 3 again

    3.5 Random crashes after playing for some time or at the end of turn
    If the game crashes to the desktop seemingly at random and without any obvious cause or at the end of a turn, it is very likely the game goes out of memory. Lowering your resolution and graphical quality in the Age of Wonders III Launcher should normally fix this.

    If you’re using a 32-bit OS you also might want to check this

    NOTE: Virus Scanners (and other programs like Samsung SSD Magician) might limit the available resources to the game. Try disabling this software during play.

    3.6 Overheating issues
    If your GPU is overheating you might need to check the airflow of your system.

    Age of Wonders III also features settings to throttle the power of CPU/GPU. Please open the Age of Wonders III Launcher and go to the Graphics tab and enable ‘Wait for GPU’, set Quality Mode to custom and turn SSAO Quality off.

    3.7 Can’t Right click (Mac)
    In the newer version of Mac OS the ‘right click’ is defined differently when using the trackpad. By default it is a two-finger click anywhere on the trackpad.

    You can redefine it so that ‘right click’ happens when you click in the bottom right corner. See this link.

    3.8 Linux Graphics Issues, Run game without proprietary drivers
    To play AoW3 with Linux open-source (AMD) drivers you need to have the latest edition of the Mesa 3d Graphics Library. Download it from their website or look for the libraries in your distribution’s repositories. Specifically for debian 8, there is a more recent edition of the libraries in the jessie-backports repository.

    4. Multiplayer

    4.1 Poor connectivity
    The game requires an open connection as advertised in the system specs to properly play online. Please check http://ageofwonders.com/support/networking/ for basic network trouble shooting.

    Please also try the following to make sure you have an open network:
    1. Verify if port 14800 is really open using: http://www.canyouseeme.org/ [or another port you my have set custom in the launcher] NOTE: it should say the connection is refused (blocked or timed out means the port is closed)
    2. If you have multiple modems/routers in your network – e.g. university network – be sure to set your router to ‘bridge’ mode.
    3. Contact your ISP to ask how to setup an open connection on your Router.

    To create an open connection on your Router please consult the Router’s manual. You can also check this detailed howto.

    Please Note: Allow the game .exe’s and port 14800 in your (custom) firewall as well. For the Windows Firewall you sometimes might need to re-add them, to fix a Windows update glitch.

    For McAfee, go to Navigation option Firewall, and choose Internet Connections for Programs (once there you may need to add the \Steam\SteamApps\common\AoW3\AoW3.exe & AoW3_Debug.exe). Please set the default to “open to all devices” (instead of “use designated ports”). Also make sure that under Ports and System Services, port 14800 is open (“open to all devices”).

    For Zone Labs Firewall a similar procedure is needed.

    4.2 Cannot join a game in the multiplayer lobby
    If you are running in debug mode you can only join games of other users that also run in debug mode. Please run the game normally -without debug mode- and try again.

    4.3 Version Mismatch
    Version Mismatch appears when the resource files of the game are different. This should normally not happen when you run the same version of Age of Wonders III. Things that might cause this are local modified resource files and/or corrupt files on disk.

    Solution is to verify the Steam Game Cache of Age of Wonders III.
    If you’re using GoG you should reinstall the game entirely.

    Also make sure neither or all of you are playing in DEBUG mode. This is also counted as different version.

    If you’re running the Beta make sure to switch back the default branch of the game.

    4.4 PBEM: “Last turn was uploaded with a newer version than yours! Update your game.”
    This error message pops up if the last turn of the pbem-game was uploaded with a newer version than yours. If you update the game this problem should be solved.

    It might be that the previous turn was played with the Steam Age of Wonders III ‘Open Beta’ build. You need to switch to this beta branch to continue playing. To do this:

    • Open Steam Game library
    • Right click on Age of Wonders III and open Properties
    • Then go to the Beta tab and select “open_beta -“
    • This topic was modified 6 years, 12 months ago by  Arnout.
    • This topic was modified 6 years, 9 months ago by  Arnout.
    • This topic was modified 5 years, 10 months ago by  Arnout.
Viewing 1 post (of 1 total)

The topic ‘Common Trouble Shooting & Support’ is closed to new replies.