[FIXED] CPU (and likely GPU) overheating

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Help & Support [FIXED] CPU (and likely GPU) overheating

This topic contains 47 replies, has 25 voices, and was last updated by  ekziled 5 years, 5 months ago.

Viewing 30 posts - 1 through 30 (of 48 total)
  • Author
    Posts
  • #60474

    Groo
    Member

    Sitting in game (on the strategic map, not main menu), I noticed that my fans (CPU and GPU) were getting quite loud. Opening up a CPU temperature monitor, I watched my CPU temp climb from about 58 C at launch, to 88 C, when I called it off and exited. This process is repeatable.

    The problem occurs at high/med/low graphics, and with all permutations of AoW3/Catalyst VSync on/off.

    I’m on a desktop (not brand new, but not bad). Specs as follows:
    CPU: Core i5-2500K (Sandy Bridge)
    RAM: 8GB DDR3 1600
    GPU: Radeon HD 6900 (2GB Video Mem)
    OS: Win7 Ultimate

    Any logs/diagnostics you need, I’m happy to help.

    #60478

    Groo
    Member

    Also: Borderless/Windowed/Fullscreen makes no difference

    #60593

    Xerberus86
    Member

    which are your setting? try disabling v-sync ingame and setting the graphic options to ultra (they somehow seem to be slightly more fluent than high).

    i also left the standard option borderless window isntead of fullscreen. at the normal settings (vsync checked, graphics on high), my gpu fan was also quite loud (but my gpu temp was at 52 celsius). i changed the settings to ultra and disabled vsync and now i don’t have any problems.

    #60672

    Groo
    Member

    Slightly more info
    System runs hot when I’m looking at the strategic map in 3D mode. When I zoom out to the cartography level (stylized map, rather than 3D map), CPU/GPU usage and temperature drop right down.

    Baseline settings (system runs about 75 degrees):
    Fullscreen
    1680×1050
    Texture Quality – High
    Shadows – Off
    SSAO – Off
    VSync – On
    Bloom – Off
    AA – Off
    Soft Particles – Off
    Reflections – Off

    Turning VSync off doesn’t make a difference. Fullscreen/Borderless doesn’t make a difference, Windowed mode is a bit worse. Turning on either shadows or SSAO to Low increases system load (and temperature) to unacceptable levels. Bloom/Soft Particles don’t seem to make things worse. Reflections increases load a little.

    #60706

    Alockbee
    Member

    I don’t understand why some people CPU/GPU’s are getting so hot. You’re running a fairly solid VC @ a semi-low-resolution. Does your case had a decent amount of internal fans to keep it cool? I’m using a 7870 maxed-out settings on 1080P panel & have no issues what so ever.

    #60714

    Groo
    Member

    Stock CPU fan, 2 fans on VC, 2 decent case fans, and in an attempt to keep it cool, I’m running with the side of the case open for the time being.

    #60814

    Thariorn
    Member

    Does this issue persist when swithcing to a lower resolution?
    Like 1440 * 1024

    #60867

    Groo
    Member

    Reducing the resolution does mitigate the issue enough to play… thanks!

    I think for a longer term fix, 1680 x 1050 at these specs is reasonable (the graphics engine hits pretty hard), but this gets me going for the moment 🙂

    #63142

    Motasa
    Member

    You’re not the only one having this problem; got it as well. Even had my computer shut down because my CPU overheated. It seems my graphics card is doing fine though.

    Running Ultra, V-Sync and everything on, fullscreen. 1920×1080.

    Desktop:
    CPU: Core i7-2600K
    RAM: 8GB DDR3
    GPU: Nvidia 560ti (1GB Video Memory)
    OS: Windows 7 Home Premium

    #63735

    Thariorn
    Member

    Seems like in some cases the game uses the CPU instead of the GPU to process the game. :S

    #64089

    Groo
    Member

    I’m definitely seeing load on my GPU

    #64765

    ron burgundy
    Member

    Same problem here makes the game basically unplayable for me :/ any help or a fix would be appreciated

    #65322

    Just throwing it out there for people who suggest disabling VSync, and I often wish everyone knew about this before gaming on a PC.

    VSync or Vertical Synchronization takes the refresh rate of your monitor and draws a picture ONLY when your monitor draws a frame.

    Let’s pretend that you have a 60hz monitor.

    VSync OFF
    Your graphics card will give you a picture as soon as its processed it.
    You could be going up to an amazing 999+ frames per second on your card.
    However, your 60hz monitor can only show 60 frames out of those 999 frames per second.

    VSync ON
    Let’s say your graphics card is fast, outpacing 60 frames per second. It will process an image and wait for your monitor to be ready. The fact that your graphics card is constantly waiting instead of constantly working, it uses less electricity and in turn produces less heat.
    Now let’s say your graphics card is slow, unable to produce a maxium of 60 frames per second. Your graphics card still benefits from VSync ON because there will still be periods where your graphics card has to wait for the next available frame of the monitor.

    #65330

    Oh, and also the VSync option in AMD’s Catalyst Control Centre is for OpenGL applications only, not DirectX games

    #67983

    vi0lance
    Member

    I seem to be having the same problem. When I get a new game I always check my cpu/gpu temps. I’ve never seen my GPU go above 70 C, even when playing something like Rome 2: Total War on high. Within 5 mins of the first campaingn mission for AOW3 my GPU hit 80C. It’s not overheating, but I can’t believe this game should require my GPU to work that hard. I can barely maintain 50fps on low with everything turned off.

    Running Low, V-Sync on and everything else off, fullscreen. 1920×1080. Changing Screen resolution doesn’t seem to help.

    CPU: Core i5-3750K
    RAM: 8GB DDR3
    GPU: NVidia GTX 660 (2GB VRAM)
    OS: Win7 Home

    #68131

    Kuijl
    Member

    I seem to have the same problem. PC is making alot of noise while playing and it gets very hot inside 🙂 hope they will fix this soon.

    #68375

    darkneuron
    Member

    My GTX770 hits 54 degrees celcius max with the latest nvidia drivers.

    #68425

    HelplessZorg
    Member

    I have pretty much the same setup as the original poster: 6900 series Radeon and Core i5-2500K. I’m also having exactly the same issue – GPU load is maxing out when playing the game. It’s basically unplayable for me now as I don’t want to damage my graphics card.

    The game seems to running fine, but scrolling is very, very jerky – I’m not sure if this is a different issue, however.

    Just tried the beta drivers and it hasn’t fixed overheating or scrolling.

    Any help will be much appreciated.

    #68465

    Vordrak
    Member

    I am concerned about this. I have quite a lot of cooling kit – an Alienware Predator 2 chassis, an ASUS NVidia GEForce GTX 580 and silver thermal paste with a specially bought heat sink. Yet my CPU went over 80 today – I have not seen that in a long time even on several other modern games.

    #69729

    HelplessZorg
    Member

    Turning off SSAO has helped get my GPU usage down a bit – but it still seems higher that it should be. I’m getting between 80% – 95% GPU usage on the strategic map, and 70%-75% during battles. This is with Vsync on.

    For comparison, I played Borderlands 2 and I was only going up to 90%+ during gun battles with quite a few enemies. I was playing at 1920×1800 with all settings on ultra.

    I recall something similar happening with the DayZ alpha: a bug caused people’s GPUs to be fully utilized all the time and in some instances this lead to people overheating and crashing. It was eventually fixed with a patch. I hope the devs look into it to see if anything is amiss.

    #69992

    kosto
    Member

    I have also this problems.
    The fans from Laptop rotate after 15-20 Minutes on maximum high.
    The Temperature from GPU is then 90°C I tested also with more settings but ever same problems….
    This System is also then very loud and i must end the game…

    I have a Laptop with Intel I7 2,2GHZ CPU and NVIDIA GeForce GTX 560M and 8 GB RAM Windows 7 64 bit.
    All Games that i play are very silence and i have never this problems…
    Max.78 C in my another Games …..

    Plz Help so i can not play this Game.

    #70132

    steph.p
    Member

    I have the same overheating problem with this game and my Alienware 14 laptop with Windows 7, i5-4200 2.5Ghz, Nvidia GT750M-2GB and 16GB Ram.
    I must to lower the resolution to 1152×864, enable the cooling pad fan, disable Turbo Mode, lower the maximum processor state to 50% and set the GPU to ‘Moderate’. In game most of the setting are Moderate-Low.
    With this configuration the CPU temp is 60-65°C and the GPU 60°C with 75-80% usage.

    #70337

    kosto
    Member

    Hello, why answer the support not of the Question from this tread ?????

    #70798

    Merca
    Member

    strange that I have no problem with my GPU but my IOH(southbridge chip) getting overheated until I get a warning message from my preinstalled hardware monitor software as an alarm.

    SPecs:
    i7 980x (H100 watercooled)
    12gb 1600 ram
    DX58SO2
    GTX 680 4gb ddr5
    haf x case
    Windows 7

    #71181

    Arsiel
    Member

    I noticed that zooming out to the paper map hight the temp drops form 74°c to 49°c.

    #71307

    Arsiel
    Member

    I see I can’t edit, so it was a mistake it was because I was alt tabbing out of the game. My bad.

    #73283

    Arsiel
    Member

    So three times in a row. I have a AMD Radeon HD 7900 with 3072 mb mem. I had some real bad overheating I was running the latest not beta drivers running. I downloaded them again. The same drivers I reinstalled them and now my gpu temp stays stable at 40°c. I don’t have an explanation maybe they became corrupted maybe my pc is trolling me I don’t know. I’m sure it were the same divers. Anyway I hope this helps someone else.

    #73574

    Hi everybody,

    A way to prevent the GPU from running too hot is by lowering or turning of the SSAO option in the graphics options. The upcoming patch will have some optimizations too, which should lower the GPU usage.

    #74017

    ron burgundy
    Member

    Thank you this helped a lot.

    #74220

    Seigar
    Member

    Yeah…on High SSAO my GPU got to 70°c >.<

Viewing 30 posts - 1 through 30 (of 48 total)

You must be logged in to reply to this topic.