Enabling Mod Packages in the Map Editor

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Modding and Map Making Enabling Mod Packages in the Map Editor

This topic contains 8 replies, has 4 voices, and was last updated by  Gloweye 5 years, 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #228660

    Gloweye
    Member

    I tried to enable some mods for a map in the editor, and got a message:

    Access Violation at address 01346D72 in module ‘GC.bpl’. Read of address 00003B40.

    Pressing OK only gives back the same message for as many times as I care to count, leaving just task manager to kill the editor as only solution.

    I got the same message once when enabling a language pack, but had nothing else I could see as problematic back then. (well, the map disappeared and I clicked the packages button before it was back, but that couldn’t be the problem, right?)

    #228868

    Arnout
    Keymaster

    Hi Gloweye, tried with mine, but no problems here. Might be mod related, if you couldd post or email your mod we’ll have a look at it!

    #228889

    Gloweye
    Member

    First try failed, second try succeeded, when enabling the packages first and loading the language second.

    However, when I tried the second map (Cult2a), it crashed again. I know BBB gave you some files, but here’s the exact combination of mods I attempted to use. Here’s the dropbox link:

    https://www.dropbox.com/s/9ae8135in5w03cu/Used_Mods.zip?dl=0

    Note: I tried to activate all mods in there along with GR and EL at once.

    I don’t think it’s got anything to do with it but:

    Some hours after the above all happened, it seemed like my steam account acted a little weird. I don’t know if it had something to do with it, but my expansions were hidden, which was fixed by restarting steam.

    However, that was a couple of hours later, and opening the mod tools after the above problem still gave me access to everything in the game.

    #229201

    Gloweye
    Member

    Now I can’t even load the maps in the editor.

    I can boot the editor, seemingly no problem. Image: Editor Stuff, above the black line.

    I try to load map Cult2a.cam , and I get that Assertion along with the second you see in the other image.

    Level: https://www.dropbox.com/s/74amxm0ui3nmrnv/Cult2a.cam?dl=0

    Editor looks like I didn’t try to load anything, not even the name at the top of the window changes. However, any try to load something else results in an endless stream of assertions that lead me to believe the editor at least thinks it’s got a map loaded. Task Manager says it isn’t doing anything, and it also doesn’t start drawing more memory.(or at least, less than 1 MB if it does.)

    Attachments:
    #229203

    Gloweye
    Member

    Lost internet halfway. Here’s the other attachment.

    Attachments:
    #229211

    Gloweye
    Member

    did some more tests. 100% reproduce, also on Cult 2B and 3. However, Cult1 seems not to have any issue, and new maps also don’t have a problem.

    https://www.dropbox.com/s/nnkpilq5tegaeoq/Campaigns.rar?dl=0

    Here’s the set of maps – mods are above here.

    #229222

    Tombles
    Keymaster

    The crash seemed to be happening because you removed something in a mod that was being used in the map. Either a unit or a tier resource or both, I’m not sure. I’ve chnaged the code so it doesn’t crash, but for now, here is your map. I can load it in the steam version of the level editor, while using the mods you posted, so I imagine you can too.

    Attachments:
    1. Cult2a.zip
    #229239

    because you removed something in a mod that was being used in the map.

    Lol, well if you’re still working on the Frostling and Elf mods, that may be the trigger.

    #229277

    Gloweye
    Member

    Feel a bit stupid.

    It turned out to be the mod BBB had activated earlier – I didn’t turn it on, so the map missed some resources. I should have thought about and checked that earlier.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.