Fix – After Windows 10 upgrade the game doesn't start anymore

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Help & Support Fix – After Windows 10 upgrade the game doesn't start anymore

This topic contains 23 replies, has 7 voices, and was last updated by  Nicholas Steel 7 years ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #221254

    Arnout
    Keymaster

    The Windows 10 upgrade doesn’t seem to create the necessary folder permissions for the AoW3 profile folder. To fix this:

    1) Optionally: backup any save games & profile (which incl. custom heroes) first.

    Saves can be found here:
    C:\Users\you\Documents\My Games\AoW3\Profiles\accountname\SAVES

    Profile files:
    C:\Users\you\Documents\My Games\AoW3\Profiles\accountname\accountname.APS
    C:\Users\you\Documents\My Games\AoW3\Profiles\accountname\accountname.APD

    2) Then please delete the following directory:
    C:\Users\you\Documents\My Games\AoW3

    3) Now create the same folder again C:\Users\you\Documents\My Games\AoW3 and give it full file permission to the windows 10 user you’re logged on.

    4) Start the game under your triumph accountname again by launching it from Steam

    5) Optionally: quit the game and overwrite the .APS and .APD files to get your custom leaders back

    This should fix the problem!

    #227832

    I tried this, what ended up happening was all permissions for the folder became lost. I can no longer view the folder contents or its permissions, can’t edit permissions for the folder, can’t delete the folder, can’t rename the folder, can’t claim ownership of the folder etc.

    It’s completely locked me out o_O and I dunno what to do now lol. This has of course prevented me from playing the game too.

    #227855

    Arnout
    Keymaster

    If you login under your local administrator account you should be able to set these permissions again.

    #227954

    I resolved it via using this “special” administrator account: I had to use this admin account to remedy it: http://www.ghacks.net/2014/11/12/how-to-enable-the-hidden-windows-10-administrator-account/ even though my account is technically already a Local Account set as an Administrator.

    #229675

    Fragsie
    Member

    I have tried your fix and am still experiencing the same issue. I’m on windows 10, 8Gb ram, 6x 3.5 GHz, radeon r7 6Gb. there was no issue before the update.

    I can sign in as a guest, but not with my username, this is with a clean install as well.

    #229767

    Arnout
    Keymaster

    @fragsie If this game loads if you use the quest account, but not with your username you profile might have become corrupted. Could you rename the \My Games\AoW3 folder to \My Games\AoW3_Bak and try starting the game again?

    Also make sure your windows user account has full \My Games\ folder permissions.

    #229922

    ibnarabi
    Member

    Change the launcher properties to windows 8 compatibility mode.

    #230636

    Arnout
    Keymaster

    There is an update available on Steam which fixes the problem!

    #232843

    Heinous74
    Member

    THANK YOU! FINALLY after MONTHS of investigation and not being able play, this fixes my fav game! thanks heaps!

    #232865

    Arnout
    Keymaster

    Good to hear Heinous74 😀

    #233614

    Arcador
    Member

    I had the following experience with windows 10:

    1. Updated the game via the gog galaxy platform to 1.7;
    2. played a game;
    3. quit with alt+f4;
    4. started the game again – crash, unless offline profile or debug mode is selected.

    ===

    using win 8 compatibility mode fixes the issue

    (hope that helps)

    #233677

    Arnout
    Keymaster

    Hi Arcador, we fixed this bug, but the update still needs to released for GoG.
    For now using debug or win8 compat is the best workaround. Sorry for the inconvenience!

    #233748

    Hi Arcador, we fixed this bug, but the update still needs to released for GoG.
    For now using debug or win8 compat is the best workaround. Sorry for the inconvenience!

    What is this then? http://aow.triumph.net/forums/topic/aow3-crashes-at-start-up/#post-231285

    The fix for the GOG version is already available, you yourself even linked me to it, it just isn’t available on the GOG website for unknown reasons. I installed that fix after updating to v1.7 because I too was having the crashing issue and that download fixed the crash for me.

    Arcador, simply download http://aow.triumph.net/data/GoG_Fix.zip and extract the contents of the ZIP file in to the games installation and overwrite the existing EXE file. Only apply this fix if you’re currently running v1.7 of the game.

    #233835

    Arnout
    Keymaster

    Ah with the quick reply forgot to mention the patch on our site.

    #236494

    Please provide the original v1.7.0 EXE files, I can’t install v1.7.0.3 (or newer updates) without them.

    Also, it seems the patches GOG provides don’t clean up after themselves if the update failed to install.

    #236508

    Arnout
    Keymaster

    Is it possible to just download the whole 1.7.4 game?

    #236511

    Yes, but I’d like to avoid a 4GB download if possible.

    #236512

    Also, it seems the patches GOG provides don’t clean up after themselves if the update failed to install.

    My bad, I was accidentally looking at the Age of Empires folder and not the Age of Wonders III folder.

    Still need AoW3.exe and AoW3_Debug.exe from v1.7.0.0. I’m aware I should’ve backed them up, but I just didn’t for some reason.

    #236513

    Arnout
    Keymaster

    I’m afraid I don’t have these official exe files 🙁

    #236525

    You’re some what in contact with the developers right? The extracted contents of the GOG v1.7.0.3 patch would resolve the situation as manual installation skips the CRC checker. (I have a copy of it and it’s also still offered by GOG if the devs need a copy of the patch to extract its contents for me)

    #236528

    Tibbles
    Member

    You’re some what in contact with the developers right?

    You’re always speaking directly to developers(keymaster under name or triumph logo in avatar) here, there are no separate support people.

    #236600

    Oh? I figured he/she was just a Moderator or Administrator of the forum, not a Triumph game developer.

    #236604

    Arnout
    Keymaster

    Most of us post on the forums actively 🙂

    PS. did you resolve your issue by downloading the full game? Sorry for the hassle

    #236605

    No I haven’t, but I will. In the future it would be nice if you could include a copy of the original files when releasing a hotfix. Either include them in the same archive as the hotfix files or in a separate archive linked to in the same forum post/news article as the hotfix.

Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.