FX effects in unit preview panel

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Modding and Map Making FX effects in unit preview panel

This topic contains 9 replies, has 4 voices, and was last updated by  takahashi13 5 years ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #247315

    Eomolch
    Member

    Hi everyone, I was wondering if anybody knows how to make FX effects show up in the unit preview panel and not just on the tactical map. I know that it has to be possible somehow because it works for some of the units from tibbles racial variaty mod. However other than that I am rather clueless. Also the same would be nice to know for additional models which at least show up on the strategic map already, but there I don’t even know if it is possible to make them visible in the unit preview.

    Best regards, Eomolch

    #247319

    Gloweye
    Member

    You could check the goblin Untouchable. I believe that one does it.

    However, that’s not the -intended- way to build the effects in. They’re supposed not to show up in the unit panel.

    #247342

    Eomolch
    Member

    Hi Gloweye, the Untouchables came to my mind first too, however unless my game has some display bugs/issues recently they actually don’t show their FX effect in the unit preview. The same is true for wraiths and the frost giant meaning the effect will only work for those units where it is already integrated into the model in the content editor (usually with some special materials). So maybe this is what tibbles did as well, can’t really tell though since when I looked at the clb and the entries of the rpk I could actually not find any hint that there should be an FX effect at all.

    #247349

    Tibbles
    Member

    I haven’t touched the modding tools in a year, but I just had a look and you have to add them to the FMD

    View post on imgur.com

    If there is no ALIVE entry you have to make it yourself

    • This reply was modified 5 years, 8 months ago by  Tibbles.
    #247365

    Eomolch
    Member

    Hi tibbles! Thank you for the response, this does indeed the trick. 🙂 never would have thought to look at the media dictionary tbh.

    Maybe you also know the answer to another question/problem I ran into (not sure though if there IS a solution on this case) : I created an fx effect consisting of a mesh to cheat the extra model option into the unit preview as well. It worked except that the extra model is unable to rotate for some reason. So if the unit it is attached to will move around, the extra model will stay with its original orientation, making this whole “trick” rather useless. The question is: is there some way to get around this problem?

    Best regards, eomolch

    #247369

    Tibbles
    Member

    Did you add it to a bone?

    #247371

    Eomolch
    Member

    Hi Tibbles, yes I added it to a bone. It does also move with the model when it comes to mere coordinates. Just the orientation stays the same.:(

    #247377

    Tibbles
    Member

    And this is set to true?

    View post on imgur.com

    #247380

    Eomolch
    Member

    Hi Tibbles, yes, I tried with both orient effect set to true and to false just to be on the safe side.

    Maybe I should have made this clear though, but the problem only occurs if the FX effect contains a mesh. For ordinary FX effects everything works fine. I was just greedy and thought maybe I can trick the game into showing some extra model in the unit preview if I disguise it as a FX effect.

    #253097

    takahashi13
    Member

    Hello Tibbles,maybe you can answer my question? I have a similar problem with Eomolch, my extra model function not work. Thanks.

    Component:Extra Model not work?

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.