Game Crash Windows 10

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Help & Support Game Crash Windows 10

This topic contains 18 replies, has 7 voices, and was last updated by  Arnout 6 years, 4 months ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #238198

    dilldappel
    Member

    Hello,
    after a time I would play again AOW3. But I have updated to windows 10 and the game crashes after e while. Before on windows 7 and 8.1 working with out any problem. It there any solutions?
    My System
    core i7 2,2, gt 555m 2 GB VRam, 6 GB Ram
    Game Settings on minimum. Driver and AOW up to date

    THX

    #238201

    Arnout
    Keymaster

    Sorry to hear you’re having problems running the game.

    First it might be that your integrated videocard is set to default for Age of Wonders III. To change this for nVidia:

    Go to the nVIDIA control panel.
    Go to “Manage 3D Settings”, “Program Settings”
    Add “AoW3.exe” and “AoW3_debug.exe” on the drop-list and set the ‘Power Management mode’ feature to ‘Prefer maximum performance’.

    Second, if this doesn’t fix the problem, does the problem still happen if you scale the resolution of the game to 1024×768 and use low quality settings? This is to pin point if your system runs out of hardware resources / memory. Please note that also external software, like Anti-Virus, might be doing this, thus its not necessarily a hardware issue.

    Third, if both solutions don’t work could you reproduce this crash by playing the game in Debug mode and sending us your log & dump files? See howto http://ageofwonders.com/support/ 2.6 Debug Mode, Logs and Crash Dumps

    #238292

    smallgosha
    Member

    Greetings, i have kind of same problem.
    I switched to win 10 and at same time bought Eternal Lords expansion via steam.
    Game crushes every time during first loading screen(after logging in triumph account). I tried all things described above, as well deleteing AOW3 folder in …/documents/my games/ . Nothing worked.

    I attached debug file.

    • This reply was modified 6 years, 5 months ago by  smallgosha.
    Attachments:
    1. log1209_2050.txt
    #238300

    Arnout
    Keymaster

    There is an issue where steam’s auto updater left some old files in the AoW3 steam directory, which are now causing issues. To solve this:

    Uninstall Age of Wonders 3
    Exit Steam
    Goto steam install directory (C:\program files (x86)\Steam\SteamApps\Common)
    Delete \AoW3 folder here
    Install Age of Wonders 3 again

    #238317

    smallgosha
    Member

    I’ve tried, it was strange – first time whan i launched it was long, but succeded – well at lest i get to menu where i can choose to start new game, multiplayer game or etc. Then i decided to login with my account – and failed. Then i tried to run game with guest account, but failed again, i deleted folders in username/documents/my games/AoW3 and tried again with guest – failed.

    also i attached log of new run(now i got crash without previous error) and dxdiag, btw dmp file is too big(more then 512 KB)

    • This reply was modified 6 years, 5 months ago by  smallgosha.
    #238335

    fairshuru
    Member

    Then i decided to login with my account – and failed. Then i tried to run game with guest account, but failed again, i deleted folders in username/documents/my games/AoW3 and tried again with guest – failed.

    ______________
    GuL

    • This reply was modified 6 years, 5 months ago by  fairshuru.
    #238347

    Arnout
    Keymaster

    I’m afraid the slow start of the game is because of the hardware specs:(

    As you’re using an Intel HD Graphics 4000 integrated graphics, could you set the setgraphic settings to low and resolution to Windowed 1024×768?

    What happens, does it still crash at loading screen?

    #238370

    smallgosha
    Member

    My bad – i have 2 videocards – integrated and nvidia. DxDiag give description only about integrated one.

    I attached nvidia settings as well now.
    Plus logs of my attempt to run AoW3 with lowest possible quality.

    p.s.
    ah, yes, i make settings in a way that AoW3 is using Nvidia videocard. (btw it is still 32-bit process)

    • This reply was modified 6 years, 5 months ago by  smallgosha.
    #238374

    Arnout
    Keymaster

    What I don’t understand is that after you did the full clean re-install the game worked and now it doesn’t. Means either the installation is broken again (data corruption) or hardware failure?

    First of all can you verify the game cache under steam and run the game again?

    Second seems your nvidia is from driver Wed Jul 29, 2015. I’ll recommend updating this as there are many fixes made for Windows 10 in the mean time.

    Third to make sure the game picks the dedicated videocard:
    1. Go to the nVIDIA control panel.
    2. Go to “Manage 3D Settings”, “Program Settings”
    3. Add “AoW3.exe” and “AoW3_debug.exe” on the drop-list and set the ‘Power Management mode’ feature to ‘Prefer maximum performance’.

    Let me know if this brings you any further!

    • This reply was modified 6 years, 5 months ago by  Arnout.
    #238410

    smallgosha
    Member

    problem is solved
    (at least for now)

    Idk what helped exactly.
    I’ve done it together. on one hand driver was out of date (but nevertheless other games was working, like Heroes VII). On another I made check via steam and it found 2 wrong files(what is strange considering that i just downloaded game)

    thank for your advices.

    • This reply was modified 6 years, 5 months ago by  smallgosha.
    #238414

    Arnout
    Keymaster

    Great to hear it works now 😀

    #238561

    zephyrcloud
    Member

    I have also had some trouble with AoW 3 since I upgraded to Windows 10. I did a clean install of Windows 10 when I upgraded and reinstalled AoW 3 from Steam. It worked fine for several weeks, and overall it still works fine, but every once in a while when I go to exit the game program or even quit a multiplayer match, my computer will crash with a BSOD. Has anyone else experienced that?

    I’ll collect logs the next time I play in case it does it again.

    #238575

    Arnout
    Keymaster

    Sorry to hear you’re experiencing problems zephyrcloud

    I don’t think a game log will help. The BSOD will just cut the log so to say without reporting anything.

    BSODs are caused by problems with your computer’s hardware or issues with its hardware driver software. The game (or any normal software) should never cause this.

    Virusses or maleware might also be a cause BSOD as they might dig deep into Windows and gets its hooks into the Windows kernel at a low level can cause system instability

    First thing I would do is update your videocard drivers and check for any malware.

    • This reply was modified 6 years, 5 months ago by  Arnout.
    #238595

    zephyrcloud
    Member

    Arnout,

    I’m running the latest Nvidia drivers and my computer is free of malware, but my gut feeling is that the problem lies more with Windows 10 than with your game because the computer has done this to me at other times. Thanks for letting me know about the way the debug logging works.

    #238788

    Arcador
    Member

    I also experienced 2 BSOD today. Haven’t been playing since the big windows 10 november update (the one which takes 20 minutes to install).

    The first was at the end of a big combat.

    The second was at exiting the game.

    I did investigation and had the following findings:

    1. After the crash the game seem to have “corrupted” my profile settings files. Had to create a new one and copy-paste the save games. Worked as expected.

    2. Some of the save games from the “old” folder do not appear in the load menu (have checked so far only the single player ones). The ones which I did manually those are, the autosaves on the end of campaign missions were visible and were loading. Keep in mind the saves are in the folder.

    (edit: posting now since if I get the BSOD again, I won’t be able to submit this post)

    Please advise if any of the files are needed.

    • This reply was modified 6 years, 4 months ago by  Arcador. Reason: added more info
    • This reply was modified 6 years, 4 months ago by  Arcador.
    #238886

    Arnout
    Keymaster

    @arcador Sorry to hear you’re having problems running the game.

    As said BSODs are caused by problems with your computer’s hardware or issues with its hardware driver software. The game (or any normal software) should never cause BSODs.

    Any logs or dump file generating by the game are cut off by BSOD. So i don’t expect to find anything useful here.

    #238954

    Arcador
    Member

    Thanks! I see 🙂

    #239155

    raygi
    Member

    This is a global problem for the recent Windows 10 build that causes BSOD with Nvidia drivers on some cards supporting DX12. (dxgmms2.sys)
    More here:
    https://forums.geforce.com/default/topic/895902/geforce-drivers/blue-screen-dxgmms2-sys/1/
    There is one solution that worked for me.
    1) Recover windows 10 to version 1511 (build 10586.36).
    2) Then install Nvidia 347.88 driver.
    I had blue screen about every hour, now nothing after several hours of playing.

    #239162

    Arnout
    Keymaster

    Thanks for the info raygi. Good to know!

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.