[Linux, 15739] Very quick "Heap memory error" crash

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Update v1.5 – Open Beta Linux Specific [Linux, 15739] Very quick "Heap memory error" crash

This topic contains 5 replies, has 2 voices, and was last updated by  ephafn 6 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #177176

    ephafn
    Member

    Since the latest build, AoW3 often crash. This can occur very shortly after starting the game (3 minutes only the last time it happened, according to the log). The log is filled with:

    [01:26:12][ERROR][WORLD_ACTIVATE]Assertion failed: "false" 
    [01:26:13]Message: [WORLD_ACTIVATE]Heap Memory Error 
    [01:26:13]/home/lascha/Triumph/SourceSteam/Creator/EK/Source/Memory/EHeap.cpp(34): (click to open)

    Over and over again. (I attached the log in case it is useful.)

    Since it happens so quickly, I assume that this is a different problem that the earlier out-of-memory errors. Also, just prior to the crash, I’m unable to move armies, but I can do other action (like selecting armies or cities).

    Attachments:
    1. log0405_0123.txt
    #177388

    ephafn
    Member

    I just tried with the Low Graphics Quality setting, and I have the exact same bug, a crash a few minutes after starting the game.

    I will try to see if it crashes even if I do nothing at all.
    Edit: Starting the game, creating a new random map, clicking Start. After waiting 10 minutes, the game hasn’t crashed yet.

    #177414

    Lascha
    Moderator

    Thanks for reporting. If it crashes again for you, then you can always revert to the previous open beta version, like so:

    Steam Library > Age of Wonders III > Right click – Properties > BETAS > Enter code: d5ZTXswqZv9y

    You should now be able to select the branch: ‘update_v1.5_previous’. Switch to this branch. There will be an update.

    A fix shall be dropped in the next update.

    #177460

    ephafn
    Member

    Thanks, it is good to know a fix is in the work.

    And yeah, it crashes everytime I tried (except the time I tried letting the game run without doing any action).

    #177843

    Lascha
    Moderator

    Should be fixed now. Could you please verify? Thanks, and sorry for the trouble 😉

    #177993

    ephafn
    Member

    I can confirm that this bug has been fixed. I was able to play for more than one hour before the game crashed (from that other bug I reported).

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.