Mod update issues

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Help & Support Mod update issues

This topic contains 14 replies, has 6 voices, and was last updated by  Artfactial 3 years, 11 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #247166

    Eomolch
    Member

    Dear Devs,

    about 1,5 months ago it started that I couldn’t update my mods on steam anymore. Only recently I saw that Tombles was so nice to reply to me on steam in the comment section of one of my mods that there was an update to the game and updating mods on steam should work again. Unfortunately for me it isn’t and I believe I know the reason for this:

    When I had tried to get my mods updateable again a month ago it turned out that one of my game files were corrupted and I used the repair option to have a “clean” build again. However since then the game seems to treat my mods as different from the ones I originally uploaded which means inctead of updating them it will just reupload them (also, it doesn’t say anymore that the mod files were uploaded on steam before like it usually does when opening an already existing mod).

    So I was wondering if there could be any way to get around this problem. Because as of right now I can’t update any of my mods which is sad because there are some open bugs or requests from mod users that I can’t attend to this way. There is the final option to actually delete my mods on steam and reupload them but that would be very messy, especially since there exist some compatibility mods from other people including my mods which would get broken in this case (the same is true for any mods with my mods in the dependency list). So I would appreciate any hints or ideas to what I could try to do to get this problem solved.

    Best regards,
    Eomolch

    #247170

    Dr_K
    Member

    I haven’t read the other threads, so you may have tried it already.

    Did you attempt to change the image associated with the mod? To something different or the same thing with a different name.

    For some reason that was an issue I ran into a while ago, and changing the image name fixed it.

    • This reply was modified 5 years, 8 months ago by  Dr_K.
    #247178

    Arnout
    Keymaster

    Hi Eomolch, did you try updating with the new Open Beta branch ?

    #247186

    Eomolch
    Member

    Hi Dr_K and Arnout, thank you for your responses. I had tried both with the open beta branch and without it and also tried the “changing image hotfix” and it doesn’t resolve the problem. Because as I described above the problem seems to have changed for me from “unable to upload” to “unable to identify”.

    I can say this because I did some more testing today and it turns out one of my mods – the hero development mod – is still identified by the game (or rather steam) as the uploaded mod. When I open it with the package manager I get the message that it was already uploaded to steam and I could confirm that I can successfully update it without creating a new mod entry.

    However when I open any of my other mods with the package manager I don’t get any pop up window telling me it was uploaded before and indeed when I upload those mods again they are uploaded as a new mod instead of updating the old entry.

    So my assumption is that every mod on steam has an unique ID and for some reason that ID changed for my mods and steam doesn’t recognize them anymore. The question is if there is some way to manually change that ID back? (or first: find a method to read the ID for both the local mod file and the steam project to confirm this suspicion)

    #247205

    LordCameron
    Member

    I have the same problem too Eomolch, perhaps we can pool what we have in common to determine if it is a bug or we ourselves did something weird.

    The first thing that always comes to mind is I have a GOG launcher and a Steam launcher that store all the files in the same folder, but tests seem to suggest this doesn’t matter. (Still worth checking with you.)

    Um… My build number is around 700.

    My mod used to have a very long description that wouldn’t fit in the module box. (I have no clue why this would matter).

    #247206

    LordCameron
    Member

    So my assumption is that every mod on steam has an unique ID and for some reason that ID changed for my mods and steam doesn’t recognize them anymore. The question is if there is some way to manually change that ID back? (or first: find a method to read the ID for both the local mod file and the steam project to confirm this suspicion)

    Alternatively, this would be awesome if it’s possible.

    #247221

    Eric
    Moderator

    If you subscribe to the mod you have already uploaded to the workshop you should be getting a folder in your “Documents\My Games\AoW3\UserContent” directory. This folder has the name of your mod + the steam user id with which the mod was uploaded. This steam user id is between brackets. So for example. There should be a folder that looks something like ‘YourMod [12345162436512341523]’

    You can check if this is similar to what you are trying to upload by.
    1) Opening the packagemanager
    2) Load your mod
    3) Upload it (even when it does not recognize that there is already a version on the workshop)
    4) Check steam directory at “Steam\userdata\55081128\226840\remote\UGC”. Where 55081128 is your steam ID (so you obviously have something different there). And 226840 is the app id for AoW3.
    5) In this directory should be a file like ‘YourMod [12345162436512341523].taf’. In order for steam to recognize an already published workshop item the name and id should be similar to the one you saw in “Documents\My Games\AoW3\UserContent”

    Does the naming of these files / folders differ for you?

    #247248

    Eomolch
    Member

    Hi Eric, thank you for your response.

    I have checked both folders and the IDs of the mods are the same in UserContent as in the remote/UGC folder. However all of my mods are having the same ID. Is this normal?

    #247250

    Eric
    Moderator

    Yes, it’s normal that all your mods have the same ID as this is your steam user ID. Not a unique ID per mod. The ‘uniqueness’ comes from the mod name.

    It’s weird that eventhough they have the same name + ID steam it does not get recognized as a reupload. The PackageManager just asks Steam if there is a file with that name in the UGC (User Generated Content, on steam’s backend). Which apparently there is not. I wonder what files are in your Steam UGC. The PackageManager outputs this in a log. Could you:
    1) Switch to open beta branch (if you’re not already)
    2) Open PackageManager
    3) Load your mod (no need to try and upload or anything else)
    4) Close PackageManager
    5) Now there should be a log in your “\Documents\My Games\AoW3\Logs” directory. Something like ‘packageManager0915_1412.txt’

    #247251

    Eomolch
    Member

    I did as you asked and since I’m no expert with this I appended the log to my post. There are a lot of unregistered class ID exceptions. Apart from that it seemed to me like steam had found the mod .taf, but then again I’m no expert.

    edit: since the log file is too big I had to split it into 3 parts

    • This reply was modified 5 years, 8 months ago by  Eomolch.
    #247257

    Eric
    Moderator

    You are correct, steam found the mod file. We found a bug in our PackageManager which is most likely causing this.

    Thanks for the information provided to help us track this one down. We’ll be releasing a fix in the next beta patch (probably tomorrow).

    #247271

    Eomolch
    Member

    Thank you so much, I can confirm that with the update my problem is gone 🙂

    #247341

    Eric
    Moderator

    Good to hear that fixed your issue!

    #273791

    Artfactial
    Member

    It appears I am having the same issue.
    The my Tamriel mod had been giving me the ‘Is already uploaded’ message for a while, I assumed this was normal?
    But it also was generating a lot of ‘[ERROR]Exception: “Unregistered ClassID found’, without noticable effect.
    Now, however, The ModEd crashes when I load my package (after a few moments, so I assume the error messages are creating a memory overload).
    What was this Repair option Eomolch was talking about and has anyone else encountered this problem and solved it?
    I’ll add the generated crash-report of the launcher including all ClassID error’s.

    • This reply was modified 3 years, 11 months ago by  Artfactial.
    #273863

    Artfactial
    Member

    Alright, so I reverted back to a version of my ACP from earlier this month.
    Instead of the ambiguous ‘Abnormal error’ message when crashing, the editor gives me the following info, which might or might not be more helpful.

    After switching to a mor recent version it gave me an error for the EK.pbl instead of the RE.pbl, whatever that means. No script error; instead with the ‘Abnormal’ message….

    This is all highly erratic and I can’t really find a source. It has me worried.
    Please, any ideas?

    Attachments:
Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.