[MOD][WIP] Living Archons – announcement and questions

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Modding and Map Making [MOD][WIP] Living Archons – announcement and questions

This topic contains 20 replies, has 8 voices, and was last updated by  Gloweye 6 years, 2 months ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #233986

    Flenoom
    Moderator

    I discovered the wonderful possibilities of combining models through the ContentEd. And now I am creating mod with a non-undead Archons. This will be a new dwelling, I create models and Zaskow (co-author) deals with the rest.
    Now I completed the 3 units: infantry, archers, and priests. Next, I think, will be the Titan, Paladin and Avenger.



    But there are problems. Units have a different appearance for the editor and units panel, and for a global and tactical map. Two moments:

    First – headgear, which is perfectly displayed in the editor, clipped the head in the game. I can try to increase it, but then it will look horrible in the units panel.

    Second – detalization of the textures for my models becomes terrible in the game. In the units panel textures have a normal resolution, but in combat it all gets worse.

    Can anyone help me with this? Maybe it’s possible to change the level of detail somewhere in the editor? Or am I doing something wrong?

    Examples are on the screenshots:

    #233992

    Charlatan
    Member

    Hm. Could this be related to the Mipmap Settings ?

    #234013

    Gloweye
    Member

    Can’t help you, just wanted to say that it looks great. Not talked with BBB yet(who has to agree as well), but is it possible that, in some far future, we could make use of your assets for the AoW 1 mod?

    #234021

    Tibbles
    Member

    Hm. Could this be related to the Mipmap Settings ?

    Probably

    Can you show the texture settings?

    #234057

    Flenoom
    Moderator

    I’ll make screenshots of the settings when I get home. But I remember that when I tried to import my texture to the editor, there was a message “No mipmaps!” or something like that.

    Can’t help you, just wanted to say that it looks great. Not talked with BBB yet(who has to agree as well), but is it possible that, in some far future, we could make use of your assets for the AoW 1 mod?

    Thank you, and of course – I’ll share my content with other modders, it’s part of my plan.

    #234058

    Zaskow
    Member

    BTW, this issue (different look of headgear in editor and in game) presents even you use default skins.

    #234060

    Tibbles
    Member

    there was a message “No mipmaps!

    Oh, this means you exported with the wrong settings, if you can show your export dialog box I can tell you what’s up 🙂

    BTW, this issue (different look of headgear in editor and in game) presents even you use default skins.

    Different how? I’ve never had it happen to me

    #234100

    rpgllama
    Member

    I’d like to add my thumbs up for your work so far. Very nice! I hope you find an answer to your clipping problem, but as I’ve not yet delved into the murky waters of unit modelling, I’m afraid I can’t help you.

    #234124

    Flenoom
    Moderator

    I checked the Photoshop settings, and looks like that was a problem! When I started to work with this mod I didn’t pay attention to the accuracy of the settings, but now I recreate all files with the Tibbles guide and it worked! Thanks to her and I’m sorry for the dumb question ))

    For the clipping problem I found a temporary solution. For priests: make a part of the head transparent, so you’ll not see the problem areas. For archers: I made helmets as part of the model and not the subject of ResourceEd. While this is enough, I am afraid there will be problems with the re-creation of Titan (it’s a long story, I’ll come back to it later).

    #234126

    Tibbles
    Member

    Nice! I’m glad you figured it out. Looks great 😀

    #234693

    LordCameron
    Member

    This looks great 🙂 !

    For a moment I had a heart attack because your mod looked so much nicer than mine 😉 but then I realized we are doing different things so people might still love me.

    Keep up the great work.

    #234762

    Flenoom
    Moderator

    LordCameron, thanks!
    This is your mod?
    http://steamcommunity.com/sharedfiles/filedetails/?id=520091694
    I see you too planning new units for dwelling, but if you say it’s different things… Well, write to me if there is any conflict between our mods. I’m planning a new dwelling with six units, as I said.
    And I wish you success, too!

    About project updates:
    Here is the first draft version of the Titan, it requires a lot of improvement.

    #235086

    Flenoom
    Moderator

    Almost done with Titan!

    That was really hard, that bastard is composed of six different parts, and still has a lot of graphical artifacts, such as clipping, but these deficiencies can hardly be corrected, so that this guy is almost finished.

    #235093

    LordCameron
    Member

    Yeah, that’s my mod. 🙂

    I’m liking the Titan. Your modeling really *Brings it to life* 😀

    I don’t think there is conflict because my mod adds to the Archon Dwelling whereas yours adds a dwelling. Mine will also eventually (soon?) be based around alignment. Only pure good players will be seeing my archons, and only pure evil will get the default.

    #235106

    Centurion-X
    Member

    I consider that copyrights to all game content and consequently the elements from which the modders combine their new units belong exclusively to developers, so that the mods for Age of Wonders are not someone’s property 🙂 Do not compete, guys! And even more so that is no reason for envy or jealousy… And as for my personal opinion: more mods – better choice!!!

    #235247

    Flenoom
    Moderator

    Almost all skins are finished, but there are still a lot of problems, so I have a couple of questions again:
    For the Avenger, I attached the hair of the hero model. In the game hair painted in red (from black). For what reason? Hair material settings shown in the screenshot.
    And some of my textures began to lower resolution again, even though I did not change any settings. I’m going to re-create all the textures again, but I would like to know the cause of this problem.

    #235252

    Tibbles
    Member

    For the Avenger, I attached the hair of the hero model. In the game hair painted in red (from black). For what reason? Hair material settings shown in the screenshot.

    All hero hair takes on Player Colours, if you want it to stay one colour you have to copy the mesh and make a new (figure)material for it.

    Not sure why your textures are low resolution

    #235326

    Flenoom
    Moderator

    All hero hair takes on Player Colours, if you want it to stay one colour you have to copy the mesh and make a new (figure)material for it.

    Once again, thank you!

    #235351

    Flenoom
    Moderator

    All in one:

    I found a nasty thing: my textures are becoming muddy, even while you are playing. You can Alt + Tab the game at any time, and half of all units randomly will receive a lower resolution, and the other half will be clear. Apparently the game has some limitations related to the video memory. And my units are created by combining the models that actually means the number of figures are 3-4 times more than what you see. I think it dramatically increases the load.
    Someone of the devs can comment on my guess?

    #237212

    Zaskow
    Member

    Ok, at last I make dwelling to work in RMG.
    Question: what I must to edit to force this dwelling generating on other theme, than blighted? AoW_LevelGenerator, I suppose?

    #237215

    Gloweye
    Member

    You copied the original Archon Dwelling for the Strategic World Entity? IIRC, that one forces Blighted Terrain under itself. Considering you’ve corrected that, I believe you should check:

    LevelGenerator -> Settings -> Passes – Dwellings -> (your dwelling).

    Make sure you’re not blocking any wrong overlays here.

    That’s the only one I can find looking at my Dark Elf Dwelling(which works as expected, but is copied from Giant where applicable and which is UG-only)

    BTW, you and I should make sure to make a compatibility patch for the map generator changes. There’s gonna be people wanting both dwellings in there. What’s your current set priority? Mine’s 0 ATM, and uses only new entries aside from the RMG changes (1 edit I couldn’t avoid).

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.