Mountains in random maps

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Age of Wonders 3 Discussions Mountains in random maps

This topic contains 24 replies, has 17 voices, and was last updated by  Sunicle 7 years, 1 month ago.

Viewing 25 posts - 1 through 25 (of 25 total)
  • Author
    Posts
  • #77958

    Edwin
    Member

    On the attached pic i highlighted the problem i have with current random map generator. The amount of mountains is a little bit… too much to my liking. And these Andes go all the way north and east. The funny thing is i placed mountains on the far left scale – so called minimum. Anybody else have the same problem? Or did i made a mistake in assuming the left side to be “less” and right side to be “more”?

    Attachments:
    #77969

    NamelessLime
    Member

    Wow… I have not seen that before. Looks like a bug to me. You’re not wrong about the sliders and I haven’t seen anything like that in my playthroughs so I think it’s just an error in that particular generation. Does it often generate like that for you?

    #77991

    Edwin
    Member

    Actually, it’s the second time in a row. Before 1.09 it never happened. It never happens when i play islands or continents map either. But Land maps seems not to like me

    #78001

    Reefpirate
    Member

    I think mountains are built into the map generation no matter how low you turn the slider… I turned it way down once, and you still get these valleys between mountains as paths, it’s just the paths were a bit wider and more ‘open’ with more clearings in the mountains, etc.

    As for the number of mountains in your pic… I’ve never seen that many before ever so something strange is going on there!

    #78006

    Oh wow, that’s crazy. Awesome, but crazy. Can’t say I’ve ever seen something like that happen but I have seen the “all the way left = off” not actually listening. First time I tried to nix artic from a game I spawned in a never ending ice field.

    Perhaps sometimes when you set the slider to “none of the things” it instead gives you ALL OF THE THINGS!

    #78013

    Sugar Rush
    Member

    Oh wow, that’s crazy. Awesome, but crazy. Can’t say I’ve ever seen something like that happen but I have seen the “all the way left = off” not actually listening. First time I tried to nix artic from a game I spawned in a never ending ice field.

    Perhaps sometimes when you set the slider to “none of the things” it instead gives you ALL OF THE THINGS!

    Ah, the Gandhi bug.

    #78055

    cccactus
    Member

    I’ve seen this before too, I once had a map that was 3/4 mountains, wish I took a screenshot. An underground map that is mostly rock is quite common, I guess this is the surface equivalent. Don’t know if was intended to work like that or not.

    #78058

    Bluemagic
    Member

    in my random map are many mountains too…
    (xxl map, geography slider not changed)
    This map was generated before patch 1.09, I believe.
    Screenshot here:

    #129268

    Azitar
    Member

    Same problem here. Mapsize xxl, land only, current build. I started several games with geography sliders all to the right, all to the left, all except for mountains and walls to the left or right, and other combinations. I ALWAYS get a map full of mountains.

    I did a fresh install of the game twice (including the deletion of savegames and settings). I also tried the beta (v. 1.431). The problem persists. Seems to be bugged. Please help or fix.

    Here some screenshots of some of the maps I got:

    #129270

    Azitar
    Member

    Pictures

    #129285

    Fenraellis
    Member

    While I would agree that the default(middle) settings seem to be generating more mountains than they use to be, such that I usually set it at about 30%… I’ve never had that many mountains as in your pictures. Wow.

    Well, there was this one game many months ago, where around 50% of the surface map was a SOLID BLOCK of mountains. That was a while ago, though, and I feel like it was partially a glitch related to the presence of Underground in that game.

    #129287

    Gloweye
    Member

    Well, thats not the entire blocks of mountains the thread is about…

    #129292

    Azitar
    Member

    Well, thats not the entire blocks of mountains the thread is about…

    yeah…didn’t find a better fred though 😉 And I found it to be very similar to what the OP reported. But also posted this in the bug section, since no matter what settings I try I always get this much mountains. Must be bugged.

    #129294

    Hide
    Member

    I know there was another thread a few months ago about the same problem with the slider but it was another slider ( water I think ). – What Sugar Rush called the “Gandhi bug”.
    Try placing the slider slightly more to the middle instead of going full to the left. Maybe that will help.

    #129302

    Azitar
    Member

    I know there was another thread a few months ago …

    No matter what settings (mapsize, difficulty, starting distance, whatever) or where i put ANY of the sliders, I still get this.

    #129304

    Hide
    Member

    <div class=”d4p-bbt-quote-title”>Hide wrote:</div>
    I know there was another thread a few months ago …

    No matter what settings (mapsize, difficulty, starting distance, whatever) or where i put ANY of the sliders, I still get this.


    Even if you don’t put the mountain-slider at the far left?

    #129308

    Azitar
    Member

    Even if you don’t put the mountain-slider at the far left?

    Not even then. Not if I only put the mountain sliders at the middle, at the far left, a bit to the left, a bit to the right, … not if I only move the mountain slider, not if I move one other slider, not if I move several sliders, and not if I change any of the other settings. It very much seems that it always puts in as many mountains as the generating algorithm allows and even a fresh install doesn’t pervent this.

    #129337

    Mourioche
    Member

    The setting i use in my game is middle map/ground/underground/default but with 25% of montains instead of 50%

    I think there is very often too many mountains.

    And (this was in an old post, i’ve found again.. deep in the forum), sometime ground can be partially full of mountain in order to equilibrate something with some configurations of underground.

    #129553

    Jomungur
    Member

    I agree, there are too many mountains on randomly generated maps and tweaking the slider doesn’t seem to help much. This occurred after the last big patch- maybe they tweaked the RMG settings?

    It gives a big advantage to flying and floating armies. Also it’s unattractive aesthetically.

    #129557

    Garresh
    Member

    I agree mountains are a bit excessive but this bug has existed since release. It happens more often on maps with underground in my experience. I’ve never had it wirhout underground…

    #129562

    jb
    Member

    I’m sure it’s just coincidence…since part of a RMG is ‘random’…but when I set Roads to Many, I see far fewer mountains.

    Again, this may just be coincidence and maybe roads are overlayed last.

    #129614

    Gyg
    Member

    Just finished a Large map without underground with Mountains set to like 40% of the slider. The attached file presents about 90% of a whole map. Mountains, mountains everywhere! 😛

    Attachments:
    #129634

    Jomungur
    Member

    agree mountains are a bit excessive but this bug has existed since release. It happens more often on maps with underground in my experience. I’ve never had it wirhout underground…

    I’m pretty sure something was changed in the RMG algorithm post-patch with regard to mountains. Cities were tweaked as well: Average cities with 2 players used to have 6 independent cities, now it’s more like 10. And I think I see more wetland patches (to help goblins, maybe?)

    #130210

    Azitar
    Member

    Thank you all, appreciate your comments. Anyhow, it’s not that I just get “some more mountains than I liked” or that the sliders just “don’t exactly do what they should”. But I get my map FULL of mountains NO MATTER what ANY of the settings are (the sliders, and all else). So what I describe is not just a lack of responsiveness of the sliders, which might have existed since the beginning. What I say is: I can NEVER get a random map which is not 90% mountains. Please look at the pictures in my original post, they illustrate what I mean.

    This guy seems to have the exact same problem:

    Just finished a Large map without underground with Mountains set to like 40% of the slider. The attached file presents about 90% of a whole map. Mountains, mountains everywhere! :P

    #130237

    Sunicle
    Member

    Sometimes the surface will be a more limited area, like an underground. The amount of players placed on a layer is the most crucial factor.

    This is a common type of underground, with one player starting there:

    The same thing will happen above ground if only one player starts on the surface:

    This has absolutely nothing to do with any slider setting. The RMG sometimes creates a smaller play area based upon the amount of players.

    I’m not saying in all the pictures in this thread this is what’s going on, but in some it is.

    Apart from that, it was the designers’ choice to keep the maps quite mountainous, even with a relatively flat setting. Maybe the influence of the sliders could have been a bit stronger, but with few mountains and little vegetation the maps start to look pretty empty and bland, this may be what the designers are trying to prevent.

Viewing 25 posts - 1 through 25 (of 25 total)

You must be logged in to reply to this topic.