[WIP] Saving game and then surrendering the same turn saves the surrender

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Help & Support [WIP] Saving game and then surrendering the same turn saves the surrender

This topic contains 5 replies, has 4 voices, and was last updated by  melkathi 8 years ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #68121

    Fanboi1234
    Member

    As title. I saved the game, and after doing so surrendered to see the powergraphs (which I feel should be available while playing, but I digress). When I went to load the saved game (not the autosave) it loaded up and showed that I’d surrendered. That sucks – the game is gone now. I should think it’s not intentional?

    #71930

    Hey Fanboi,
    I will look in to that issue.
    Thank you for reporting!

    Kind regards,
    Pieter

    #83685

    Dear Fanboi,

    I have tried to reproduce this but I did not have any succes.
    Do you still have this issue?

    Sincerely,
    Pieter

    #86328

    Fanboi1234
    Member

    Just tried it, and nope, game loaded fine. I wonder if this had to do with the original release version (since I’m on 1.09 now). Regardless, thanks for taking the time to look into it!

    #86484

    Mourioche
    Member

    “Save game” always use some time, are you sure you’ve see the message “game saved” before you surrender ?
    Perhaps here something depends on the computer and how quick it can “save” (Perhaps save game are compressed ?) ?

    And, if you “save” and then “surrender” without leaving the menu where are buttons “save” and “surrender”, what append ?

    #86647

    melkathi
    Member

    There is something odd with what information savegames are saving.
    Could be a related issue to the one I reported a while back about savegames affecting the AI movement for the rest of the turn.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.