Tactical Combat – Environment Sets

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Modding and Map Making Tactical Combat – Environment Sets

This topic contains 1 reply, has 1 voice, and was last updated by  Gloweye 4 years, 12 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #236585

    Gloweye
    Member

    So, there’s a number of vanilla Environment sets which are generally bound to tactical combats and map layers – the second version is temporarily overridden by Cosmic Events, the first optionally by combat enchantments.

    In regards mainly to the second one, I’m trying to find out how to tell the rpk’s they exist. Here, I will describe my attempts.

    1. Method clb

    Sadly, nowhere in any clb is there a way to link to an outside Enviromental set. I highly doubt that there’s a link directly between clb’s and tam’s (Tactical Combat Map files), since it seems everything in a clb that’s tactical combat related is defined in gameplay terms in rpk’s at specific places. My conclusion is that clb files can in no way link env sets for rpk’s to use, unless it’s specifically hidden for us.

    2. Method rpk

    There’s a number of environmental sets visible from rpk’s. For example, you can open up AOW_TC_THEMEBLIGHTED.rpk, and go Settings -> Bli_Environment and you’ll see a number of entries starting with sur_-, like sur_WellofSouls. These have an “Environment Set Link”, in our example TC_WELLOFSOULS. Main identifier is Library, secondary Resource. This made me check clb’s in the first place, despite Library being identified with “(none)”

    My main issue is how this list is acquired.

    What we Know:
    Hierarchy: Not all Environment sets are visible from anywhere. They are from the editor, but that uses a file browser to search for them. For example, from AOW_TC_THEMEBLIGHTED.rpk you can see some entries named for example AOW_THEME_BLIGHTED. This particular example is invisible from other rpk’s handling this kind of thing. In my case, I tried CosmicHappenings.rpk. I can’t access the AOW_BLIGHT_THEME there, and neither can I access TC_WELL_OF_SOULS. The Blight pack can’t see the Cosmic Happening entries, like Cosmic 09. However, both of these can view the HEROPANEL Environment sets. Ergo, there’s a hierarchy somewhere here, and different RPK’s have different access patterns.
    Two names: There’s a minimum of two names for each set. One is the file name, and the other is the name that the game knows it by. For all vanilla .env files it’s the same, yet it’s possible to have it different. Not that surprising, but can’t hurt to know. This also means that for every duplicate I tried to make, I’ve put the set through the editor’s env set editor to rename it internally. Noteworthy that the Mod Editor always view these names in all CAPS, while the Editor shows lower- and higher-case letters. This may signify three names, but I’m not sure. Mod Editor capitalizes more without need, like the name of every .rpk in your acp when you load a acp with packs already open.

    Attempts:
    RPK link -> Can’t find anything. Also seems unlikely, because it should have said Category, not Library by the primary identifier. And it should have been filled. However, it could have slipped past my radar due to the unknown rpk hierarchy.
    Folder Location -> Vanilla packs follow paths like Environments/TC/Structure/name.env. I’ve put my .env test files both in the vanilla file paths, as well as in the equivalent path of my mod folder. No result.
    Internal Link -> When you copy and rename a vanilla pack, it won’t show up. This is attempted both with just renaming the file and renaming it by editor as well. Along with fruitless attempts in RPK/clb’s and folder locations, this is my best bet. However, this would mean that renamed duplicates should be able to be found by the rpk’s. The only way for the game not to would be an internal detection of duplicated ID’s or something similar. However, no such errors were in the logs of either the Map or Mod Editors.

    IIRC, a while ago there was someone who was able to overwrite the default subterranean env set with a surface set renamed to the same name. However, I can’t find any evidence of this. If this would be possible, that would indicate a option to include new .env sets somehow using the folder method?

    If there’s a Dev willing and able to help out with getting the rpk’s to spot the .env sets, I’d be more than grateful.

    #236617

    Gloweye
    Member

    If there’s a Dev willing and able to help out with getting the rpk’s to spot the .env sets, I’d be more than grateful.

    Please?

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.