The V1.8 “POSEIDON” patch in Steam Open Beta

We’ve moved over to the paradox forums. Please come visit us there to discuss:
You can still read the collective wisdom - and lolz - of the community here, but posting is no longer possible.

Home Forums Age of Wonders 3 Discussions The V1.8 “POSEIDON” patch in Steam Open Beta

This topic contains 92 replies, has 41 voices, and was last updated by  rilian-la-te 2 years, 7 months ago.

Viewing 30 posts - 61 through 90 (of 93 total)
  • Author
    Posts
  • #252644

    Jaduggar
    Member

    I dislike it intensely, but Endless Legends has garnered a following.

    I don’t know if I would consider that game to be “high end”. It’s a very good show for an indie 4X, and it deserves its fandom, but I would say it’s still pretty low budget compared to anything Triumph, or certainly Firaxis, can put out.

    As far as whether or not that game is any good, well… it has some creative ideas, and the factions are very diverse, but ultimately it falls flat on its ass for a completely broken economy and mediocre combat mechanics.

    #252652

    Khelle
    Member

    @thariorn you are totally right, the sci-fi game does not have to have an insterstellar travel – it was just an example. What I meant to say is that, the sci-fi TBS games are much more complex than ther fantasy counterparts and they always end disaster or the average at most. I don’t want to see Triumph suffer because of that.

    @jaduggar I am not sure if you are right on this one, the ES2 being created by Amplitude seems to be quite high-budget production, in terms of strategy games.

    #252655

    Lennart Sas
    Keymaster

    The official 1.8 version is now live on both GoG and Steam. Thanks for checking out the open beta!

    #252657

    fulano5321
    Member

    Is there a patch on GOG, or do I just need to download the whole game again?

    Or will it update through GOG Galaxy? I haven’t tried using that one yet.

    #252662

    SeeR
    Member

    The new patch is wreaking havoc on the currently running pbem games

    any game that uses mods ( lets say specifically the pbem beta balance mod )

    is now giving message ( you are using different version of pbem beta balance mod )
    and will not allow turn to be played

    nevermind trying to play a turn on one of my fancy 10 mod games

    anybody else having similar issues ? I bet there are a ton of frustrated pbem players currently……

    #252663

    Eskild
    Member

    I have the same issues. I can provide screenshots and savegames if need be.

    #252664

    xlnt
    Member

    +1
    all games ongoing with one of the community made balance modes (stable and beta) are now not playable ):

    in all fairness this is not exactly something Triumph did to us but the whole pbem community is affected, including 3(?) tournaments and we will all be grateful if there is some help. Probably we need new versions of the modes.

    #252665

    SeeR
    Member

    Or perhaps some type of just temporary ( All pbem OVERRIDE / OVERWRITE thing )

    #252666

    Eskild
    Member

    Well, just to be clear regarding my issues. I actually took two PBEM turns today using the balance mod main branch only (~16:00 +1 GMT) and with that one plus racial class unit reskin (at 19:45 +1 GMT), however I´m not sure that my game was updated with the patch for these games (even though that happens automatically, right?).

    #252667

    anybody else having similar issues ? I bet there are a ton of frustrated pbem players currently……

    Yes, we have the same issues – both me and my friend got the same message ‘you are using different version of 6 mods’ for all the 3 PBEM-games we are running atm 🙁 . We use 16 mods in total.

    We thought that maybe these 6 mods were causing problems because these were updated since we started our PBEM-games (the other 10 mods are not afaik); although we never update mods on our PCs after we start a couple of PBEM-games. So, we tried to replace all the mod-files with the original mod-files when we started our PBEM-games (I always save these files) but to no avail.

    I kind of conclude that the message ‘you are using different version of x mods’ is not correct. I think the save-game on the PBEM-server has been uploaded with the old patch – and now with the client patched to the ‘Poseidon’ patch, it somehow gives this message of ‘you are using different version of x mods’.

    I hope this can be fixed.

    Apart from that: good job to provide a new patch 🙂

    #252668

    Motasa
    Member

    Despite having fiddled with almost every rpk file, I only had to restore or rework a few things here and there to get my mods to work with this patch.

    #252670

    Yigg
    Member

    Is there a patch on GOG, or do I just need to download the whole game again?

    Or will it update through GOG Galaxy? I haven’t tried using that one yet.

    Mine updated automatically and quickly through GOG Galaxy. It’s pretty handy.

    #252676

    Jaduggar
    Member

    @jaduggar I am not sure if you are right on this one, the ES2 being created by Amplitude seems to be quite high-budget production, in terms of strategy games.

    I haven’t played any of the endless space titles, they won’t launch on my PC for reasons I can’t even guess at. The first one will open, but it freezes my computer as soon as I click anything, and I can’t even ctrl+alt+dlt out of it, I have to power off my machine.

    That being said, I guess you could argue that ES2 is pretty high end, but I was mainly taking about Legends.

    #252681

    Hiliadan
    Member

    all games ongoing with one of the community made balance modes (stable and beta) are now not playable ):

    The main branch of the balance mod was updated by Zaskow so now games with this mod works on v1.8 Poseidon. The beta branch will probably be updated today so that it works too.
    For other mods with issues, you probably need to contact their authors so that they do a small edit in their mod to say to the game that the mod works with v1.8 (it’s a quick edit, very simple).

    #252687

    Gloweye
    Member

    Fixed PBEM exploits. More information after official release, for obvious reasons.

    sooo…. ? (this is what the new news post says)

    #252688

    Hiliadan
    Member

    I would rather wait after we test that it’s really fixed before revealing the stuff. I was not able to test because I have a GoG copy and I didn’t hear anyone testing the stuff (few people knows about it mercifully).

    #252706

    Zuendhoelzli
    Member

    what were the “Fixed PBEM exploits” ?

    #252761

    SikBok
    Keymaster

    Ehm … Did u fixed that after send an economical proposal of mana or gold to a teammate we Cant send no more messages?

    Don’t remember seeing a ticket for that. Can you point me to the bug report for that, so I can add it to the list for the next patch. Thanks!

    @PBEM Mod issues, please see this topic for the latest and greatest.

    #252764

    Tasslehoff
    Member

    Don’t remember seeing a ticket for that. Can you point me to the bug report for that, so I can add it to the list for the next patch. Thanks!

    @sikbok in the diplomacy panel, If I send gold (or mana, etc…) then I can’t sent text message to that player!

    #252910

    jconsort
    Member

    Love the game, minor question. Will the new population producing structures be affected by the expander talent? Or the necromancer corrupt sourCe etc. ? Thanks in advance and sorry if this has been asked before.

    #252931

    hugin7
    Member

    I do not see an option in GOG to patch the game; the only available option is to uninstall the game and reinstall a full 1.8 version, along with the DLCs. Am I missing something? I do not use GOG Galaxy and prefer to download patches manually.

    #252932

    Hiliadan
    Member

    I was in the same situation as you and I thus installed GoG Galaxy and then it patched the game by downloading 185 Mo instead of 2 Go. I think that’s the best thing to do.

    #252935

    jbfarley
    Member

    I’m not sure if it’s because of one of my mods or what exactly, but I don’t have any option to create a structure on the water

    #252985

    ICBM16
    Member

    I’m playing a multi-culture game and I’ve experienced this. The Orc, Draconian, and Tigran Builders (since I’ve built those) don’t have access to the Water Fortress action, but the Human Builders do have access to the Water Fortress build action. Hope this gets fixed.

    #253021

    Hiliadan
    Member

    What mods are you using both? Racial Watchtower? Or the balance mod? If it’s the 2nd, did you update it to the latest version? If it’s the 1st, I’m afraid you’ll have to de-activate it to be able to build stuff on water. And it’s possible that Builders built before the patch with one of these 2 mods will not be able to build on water (not sure though).

    #253042

    Gloweye
    Member

    It shouldn’t matter if you build the builders before, but it does matter that no mod changes the builder, or that it’s updated to incorporate the changes. Any non-updated mod touching the builders will interfere.

    Regardless, it’s the mod that should fix this.

    #253052

    Mourioche
    Member

    Glad to see that there is always updates for this game.

    And you know what ?
    After some times on two other games, i play this one again (before this lastest extension)
    This is the mark that this is a good game.

    I have a question:
    How about the mod ‘old man of the see’ (that i don’t try to use yet) and this extension ?
    They are compatibles yes i think; but about gameplay, did they match ?

    • This reply was modified 2 years, 11 months ago by  Mourioche.
    #253112

    Mourioche
    Member

    I noticed something :

    1) When you select an hero or the leader, on the windows where you can see details from this hero/leader, the arrows to pass to the next hero/leader do nothing.

    2) And, i don’t know if it is expected, by now heroes are on screen without their mounts.
    I don’t know, perhaps i prefers…

    [edit]: Two turn after, these 2 modifications vanished and heroes windows are like they are before patch… (and i’m on the same game…)
    … Very strange …

    • This reply was modified 2 years, 11 months ago by  Mourioche.
    #253124

    stellarrat
    Member

    I don’t know if this is just incredibly bad luck or a new bug, but I had a battle in a legendary Sphinx temple the other day where four out of five petrify attacks by Eye Tyrants were successful against Dwarven FirstBorn Champion level units. I’ve never seen that happen before in the three years I’ve been playing this game. I don’t know what the odds are of that happening, but it seems like they should be very, very low.

    #253131

    Gloweye
    Member

    I don’t know if this is just incredibly bad luck or a new bug, but I had a battle in a legendary Sphinx temple the other day where four out of five petrify attacks by Eye Tyrants were successful against Dwarven FirstBorn Champion level units. I’ve never seen that happen before in the three years I’ve been playing this game. I don’t know what the odds are of that happening, but it seems like they should be very, very low.

    Immolated reduces your resistance a bit, so that might help a bit. All in all, I think it’s really just bad luck. (Also, they’re called watchers.)

Viewing 30 posts - 61 through 90 (of 93 total)

You must be logged in to reply to this topic.